How’s the weather out there? Here, as I write these words, it is yet another dark day with heavy sleet pouring down from the sky and equally dark slosh on the streets. Charming. Come on, winter, behave yourself, it’s March already!

Back to the business though. Today’s quick stability and performance update fixes the following issues:

  • DNA-49372 – Opera stops responding/freezes on various sites on Windows 10
    The infamous issue on Windows 10 should now be gone. Please check whether your Twitter, Facebook and similar sites work for you.

  • DNA-47405 – Monitor won’t go sleep when Opera has animated theme
    Your machine should now utilize the display sleep mode when the animated theme is in use.

  • DNA-43687 – [Linux] Mosaic of tab bar artifacts instead of Web UIs when hardware accelerated
    We’ve finally made it. Linux users, please let us know if you still have any visual artifacts when using hardware acceleration.

Installation links:

The changelog, which contains only the fixes mentioned above, can be found here.

About Aneta Reluga

Working at Opera since November 2010. Keen photographer, avid Pentaxian, occasional oriental dancer and wannabe dramaculous native language wordsmith; currently in the Desktop QA Team.

Back to top
  • iPristy

    36 Stable would be even better.

    • Olli

      Next week, I guess.

      • Spideymang

        Cool!!! I’m waiting for it and now that chrome (the base of opera with chromium) in its 49 edition has the ability of hide extensions as in this article explain http://www.laptopmag.com/articles/hide-chrome-extensions hope this feature comes in the new edition of my fauvorite browser 😀

  • José Alberto

    I use turbo mode only for 1 site every day the site is http: 1 day turbo works fine showing webP format, another day does not work showing .jpg format I´d like to get stability in turbo mode.
    in that site porn site, people post pics using BBCode using host servers to upload their pics to show in that site, E.I. of image hosts used are kn3 or imgbox or pic upload and another

  • Cqoicebordel

    Don’t forget to update the available source in http://arc.opera.com/pub/opera/source/desktop/ to this release 🙂

  • drkrvn

    I’m doing some heavy calculations on my machine with process priority “lower”.

    Unfortunately many sub-processes of Opera are set to “lowest” which makes Opera unusable during heavy CPU usage.

    Is there a way (a flag) to make the standard priority “lower” and not “lowest” ? Manually setting it in the taskmanager is not an option!

    • Aneta Reluga

      That’s an interesting use case to consider, thanks. I’ll forward it further.

      • drkrvn

        Great, thank you 🙂

    • xirit64

      Use Process Hacker it’s far superior than Task Manager, you can save your high priority and even the I/O priority.

      • drkrvn

        As I said, manually setting it in any Task Manager is not an option.

        • xirit64

          With Process Hacker you only do it once and it will help you until (and if) they will implement such thing, plus why should it not be an option for you and instead they should obey to you. Egoist much?

          • drkrvn

            It is definitely a nice workaround, although I don’t like having additional programs running, so thanks 🙂 . Another workaround would be to set my workers to lowest.

    • Data Keeper

      This was asked may times and no solution so far.

    • Spideymang

      Hope Opera can fix / work around some details with the cpu usage, specially when the browser plays video. I had to active the flag “Disable hardware-accelerated video decode” to have a good respond with low cpu usage at playing videos online

  • Eugene Tareyev
    • Aneta Reluga
      • Pavel Aleksandrov

        I manually updated to 2066.92 yesterday before this post was made, and nothing changed in how my opera behaved. Still constantly becoming unresponsive, speed dial takes a while to show up, every time I re-open the browser I have to wait like 5-10 seconds or more before I can do anything, and almost all pages open up and stay white for a few seconds even after they’ve been fully loaded. Aneta, did you get my PCs’ specs that I sent you?

        • Aneta Reluga

          I totally missed it, please give me the link again Pavel (a lot of things happen here so I have to be asked the second time sometimes 🙁 Sorry!).

          • Pavel Aleksandrov
          • Aneta Reluga

            Ok, thanks, now I got it. Pretty strong ones I’d say, so it is all weird.
            One more thing… Does this happen always, I mean even after the fresh system/Opera start? I’m hypothesizing here that maybe some leak is present which would be gone if you restarted the machine as well.

          • Pavel Aleksandrov

            It happens always without exceptions. A fresh Opera start is a bad thing, because starting it also takes extra long. I now generally keep it running because otherwise it takes 10+ seconds to be able to click things on the speed dial or to go to pages that I’ve typed into the address bar. If you want I can record a video and show you what it’s like.

          • Vux777

            it could help devs to narrow down the problem
            – do you use firewall?..and if, which one?
            – any anti-virus programs?
            – did you disabled some of the windows services, like Superfetch?

            what about other programs/browsers…do they also start slow?

          • Pavel Aleksandrov

            It was Avast -.-. Here is a video showing the effect. Still, this is something in Opera that needs to be fixed, not Avast. Good luck with this one.
            https://youtu.be/cYe9qczWAEA

          • Vux777

            I had the same problem with zonealarm long time ago, if some kind of system protection was turned on.
            maybe Avast needs to recognize Opera as legit app for accessing system files, instead of checking every request

          • Pavel Aleksandrov

            Adding the program files opera directory to its file system shield exceptions seems to work. I’ll play around with finding a better solution. Still, why did this start with Opera 36, and why doesn’t Chrome have this problem?

          • Vux777

            no idea
            -maybe because of popularity, Chrome is better integrated in filters
            -maybe Opera does things differently, they do work on speeding chromium and implementing their own solutions (memory etc.), maybe some of those things is new to Avast…

          • Pavel Aleksandrov

            Here is a video of what happens and what was causing it. Please fix it because I would like to be protected AND use Opera 😀
            https://youtu.be/cYe9qczWAEA

  • http://www.youtube.com/user/max1cp?feature=mhum Maxim

    I actually cannot believe you guys fixed the two most annoying issues with the browser, finally. I will test and report back if I have issues still.

  • https://vivaldi.net/unity/profile/chas4/6-blog Chas4

    Weather is very warm (we have fire danger in Winter)

    2 stable build updates a week apart, has been a bit since that happened

    • Marcin Mitek

      Fixes were important enough to make this happen.

  • LoverOfLife

    Why with scroll click, speed dials always opens next to home tab, and why not to the end ? Is there a fix ?

    • Aneta Reluga

      You mean, when you open a speed dial item with the middle-click? It is natural – all middle-click items are opened that way. Or, do you mean something else?

      • LoverOfLife

        Yes, i mean with middle click. If it’s natural, why bookmarks opens at the end (like it supposed to) ? Chrome opens all links, dials, bookmarks with middle click, at the end

        • LoverOfLife

          Example: let’s say i have 2 dials, let’s call them site1 and site2. I open site1 with middle click, and then middle click to site2 it will open next to home speed dial, not next to site1, at the end. Try it for yourself and see

          • Rafał Chłodnicki

            What you are describing sounds like the bug that was already fixed on developer builds. It should trickle down to stable builds soon.

          • LoverOfLife

            Alright, thanks for confirming this & info

  • Spideymang

    Great team! Thank you Aneta and opera team!
    In Mexico city today its windy and sort of rainy

  • led9ru

    How exactly do you fix the error?
    You Write Chromium developers, asking them to fix it?
    (just wondering)

    • Nekomajin43

      Chromium is open source. They contribute to the source code.

      But Opera has its own GUI, which is not part of the Chromium engine.

  • Josip Kozarac

    Dear Opera devs, THANK YOU for fixing DNA-47405.

  • Leonardo Gomes
  • Nico

    That crash on Windows 10 was so annoying. Thank you for fixing it! 🙂

  • ktxgio

    Could you help me please? Can (and how) i manage (and add) frequent sites here?

    http://imgur.com/50pY5l0

    [EDIT]
    Ok, until 2 minutes ago it doesn’t work, now work fine! Is my pc possessed?
    [/EDIT]

    [EDIT1]
    no, doesn’t work, worjed because there was new release auto-install… but if i delete a link (because is not important for me) Opera does not replace it with an another link of frequent page visited
    [/EDIT1]

    • Leonardo Gomes

      Afaik you can’t add frequent sites in that menu. It only shows your Speed Dial entries.

      • ktxgio

        ok… have 20+ speed dial entires in speed dial home, in jumplist Opera show me first 5-6 only and if i delete it (because i want other that are listed in 15th position for example) Opera does not show me anymore… and it show me added (fixed) sites (that first were in speed dials jumplist list)

        EDIT: if i delete speed dials entires in jumplist, Opera does not replace sites in jumplist with other speed dials entires that are in speed dial home

  • ktxgio

    if i have installed Opera browser i can’t create a new usb installation for portable usb memory

    • Leonardo Gomes

      Change the installation path.

      • ktxgio

        setup program does not permit me to change, i perform usb istallation when i try new beta release… now have installed Opera Stable 35.0.2066.92 as default browser, if i can’t to create a new Opera Stable 35.0.2066.92 USB installation
        http://imgur.com/YLnnck7

        • Leonardo Gomes

          As i said, you need to change the “install path”. Then you be able to change the ” install for” field.

          • ktxgio

            sorry, didn’t understand. tested now and work. thanks a lot

  • Artiom

    Sync Speed ​​Dial is very necessary . Everything else ( extensions, themes ) is also desirable . The last thing done is developed accelerated it , which of course also important. It is hoped that in time everything will be

  • https://vivaldi.net/unity/profile/chas4/6-blog Chas4

    Scrolling up and down in the Opera Task Manager causes a CPU spike for Opera (It might go from under 1% to 50%)

    OS X 10.11.3

    • Spideymang

      Its the same for me while Im watching videos

  • https://vivaldi.net/unity/profile/chas4/6-blog Chas4
  • https://vivaldi.net/unity/profile/chas4/6-blog Chas4

    Click to play not working on http://abcnews.go.com/US/fedex-driver-soda-machine-shield-tornado/story?id=37305023 (flash player plug in)

    OS X 10.11.3

  • Izer0

    Bookmars still slow like a snail, 4000 bookmarks load for 20 – 30 seconds, searching more than 30 sec. Same on download manager, I have all my downloads there, 20 – 30 second to load list, 20 – 30 for search, OMG. It is not for heavy use or little bit advanced users. From version 35 I don’t see icons on my 425 tabs, on few icons, something went wrong.

  • PlonPlon

    SLOW….. Please FIX!
    OS X 10.10.5 (14F1605)

  • Jan Velecký

    I have 34.0.2036.41 stable Opera and it’s say, that it’s up to date!

    • Leonardo Gomes

      Run the installer to get the new build.

      • Jan Velecký

        Are you serious?
        20 versions since Opera 15 and it cannot even check if installed version is up to date right…
        This is bug report (if you don’t understand).

        • Leonardo Gomes

          I was just telling you a possible way to fix the problem.

          • Jan Velecký

            I know, thanks. But if I update manually Opera, it’s hardly repair this bug…

          • Leonardo Gomes

            Well, it seems to have worked for me at least once.

        • hassanraza

          i suggest you to switch to some other browser opera is just a piece of crap

    • http://www.blackcoder.de blackcoder

      Already tried to press F5 on opera://about ?

      • Jan Velecký

        It is checking, every time I open opera://about. Now, I tried (Ctrl + ) F5 and it doesn’t help.

  • Yeltnerb1

    Can we have a 64-bit version of Opera stable, please?

    • https://vivaldi.net/unity/profile/chas4/6-blog Chas4

      On Windows it is in testing

  • Aivier

    Can’t open help.opera.com since last year, what’s wrong?

    Ping help.geo.opera.com [59.151.98.156]…

    • Leonardo Gomes

      No problems here, it leads me to http://help.opera.com/opera/Windows/2066/en/

      Btw, i get another ip here.

      • Aivier

        82.145.215.43, Right?

        See my last comment, only China user will resolve to 59.151.98.156, if this domain resole to 82.145….I can open it , but all DNS in China will resolve it to wrong IP, so , China user can’t access Opera help more than 1 years.

        • Leonardo Gomes

          Yep, that one.

          • Aivier

            I have try search this IP, but it look like a normal one.
            I don’t know should i report this via bug report system.
            You could try some online ping tool, select ‘China’, All result from China DNS server will return wrong ip.

    • https://vivaldi.net/unity/profile/chas4/6-blog Chas4

      Try clearing the browser cache and flushing the DNS cache

      • Aivier

        If you are in China , help.opera.com will resolve to this ip , i don’t know it’s server wrong configure or blocked by China FireWall

  • PlonPlon

    Please fix Opera… It’s slows the computer so bad (Mac)… I can’t use it (both the browser and the computer). I switched to Chrome for now and wait for new Opera Stable.

    • https://vivaldi.net/unity/profile/chas4/6-blog Chas4

      How many Windows and Tabs do you have open? (I noticed a bug (tho it is in Chromium itself I think) when I get a lot of open windows (over 18) Opera slows down a bit)

      • PlonPlon

        25+ open tabs, but previous stable version did not slow my computer nor the browser. So it’s something new that was introduced with this version…

  • https://vivaldi.net/unity/profile/chas4/6-blog Chas4

    I got “This browser does not support video playback.”

    on https://twitter.com/0xcharlie/status/707350344137728000/video/1

    OS X 10.11.3

    In Safari 9.0.3 it plays, seems Twitter changed the codec for some videos

    • Leonardo Gomes

      I see that message sometimes on Windows too but it’s kinda random.

      Now, the video played fine.

      • https://vivaldi.net/unity/profile/chas4/6-blog Chas4

        Play fine for me on the 2nd try, seems like a Twitter bug

  • hassanraza

    this browser has many problem sush as twitter video playback support.
    youtube cookies supports. i dont know what the f… opera team is updating in this damm browser.
    with a every singal update this browser is becoming worst .

    • Vux777

      current beta channel has fix for it
      it will be in stable very soon

      • hassanraza

        opera is the worst browser ever . i don’t know why people are still using this browser.

    • https://vivaldi.net/unity/profile/chas4/6-blog Chas4

      I think the Twitter issue is a bug on the Twitter site (seen it a few times), Youtube might be that cookies are blocked in Opera settings

      • hassanraza

        No, its not a twitte bug videos are perfectly playing firefox and chrome but the same video is showing that your browser does not support video play back

        • https://vivaldi.net/unity/profile/chas4/6-blog Chas4

          I have seen it myself in Opera and a bit later the video player fine in Opera

  • https://vivaldi.net/unity/profile/chas4/6-blog Chas4

    Flash Player 21.0.0.182 is out

  • https://vivaldi.net/unity/profile/chas4/6-blog Chas4

    During page loads there seems to be a graphics leak as I get the cached image of another page while Opera is loading a link from Twitter

    OS X 10.11.3

  • https://vivaldi.net/unity/profile/chas4/6-blog Chas4

    Clicktoplay is broken on http://www.thedailybeast.com/articles/2016/03/11/video-shows-trump-campaign-manager-corey-lewandowski-grabbing-reporter-michelle-fields.html

    The plug in content is behind the video player controls, and the video player is a brightcove player

    OS X 10.11.3

    (they are also using Webkit vendor prefixes for the video player)

  • https://vivaldi.net/unity/profile/chas4/6-blog Chas4

    104% cpu spike on https://www.periscope.tv/w/1ypJdyXjAXqxW

    OS X 10.11.3

  • UMaster 7

    mp4 is not categorized correctly as “video” in the download section (ctrl + j) but as “other”.

  • https://vivaldi.net/unity/profile/chas4/6-blog Chas4

    204% CPU spike on http://www.someecards.com/news/so-that-happened/real-product-names/ after a bit (might be an ad or something)

    OS X 10.11.3

  • L33t4opera

    The Opera 36.0.2130.32 has been promoted to the stable channel 😉

  • michael0leahcim

    Can’t keep 36.0.2130.32 on any site for more than 10 second before the program crash

  • Moises Lima

    Hi,
    chrome.webRequest API dont work to ResourceType “object”, “other”…

    chrome.webRequest.onResponseStarted.addListener( function(l){console.log(l);}, {urls: [“”], types: [ “object”, “other”]}, [“responseHeaders”]);