Let’s start a week with a new Opera beta build.  This update includes new Chromium – updated to the version 39.0.2171.62, and couple of fixes for bugs and crashes, mostly related to different kind of plugins. It should now be more stable and crash less, but if you still notice some unexpected behavior – give us a hint in the comments or file an issue through our bug wizard. Thank you for the testing and feedback so far.


The full list of fixes is available in the changelog.

About Marcin Mitek

Tester on Windows platform @ Desktop Team since 2012. Based in Wrocław office. PC gaming enthusiast. Commutes to work on his fixie, Killer Bee.

Back to top
  • nanana1

    Thanks, Marcin, for this small Opera 26 Beta 20 update which brings Chromium version updated to 39.0.2171.62 !

    • András Ács

      Thanks, nanana1, for writing this thanks post on the Opera desktop team blog site’s comment section regarding the recent Beta update!


  • L33t4opera

    Hi Marcin, thanks for the update, and fixes 😉
    “Let’s start a week with a new Opera beta build.” – it’s a good start indeed!

    • P0lip

      it’s a good start indeed!
      Yes, awesome. 7 bugs fixed and Chromium got updated. WOW, I didn’t expect it!

      • Marcin Mitek

        This is a stabilization branch. “It contains the features we intend to ship at a quality level resembling what we intend to ship. No new features or significant changes are introduced between the major releases.” Most of the bugfixing work is done on the master branch, i.e. developer stream. We backport only handful of fixes, usually at the beginning of the stream existence (when it’s still in developer) there is more going on.

        • P0lip

          Yes, actually it is, but honestly – wouldn’t be it better when you return to Opera and Opera next? In developer stage you never release any bigger features, so this channel is pretty useless. You could bring this stuff in next (or beta) releases – together with bug fixes :). You provide bug fixes for Opera stable anyway.

  • A. R.

    How about starting something let’s say new features since O15 and bookmarks?

    • P0lip

      IMHO, if they don’t want to bring all features, then at least create a poll and let us vote for the most important ones.

    • Nick Schaedel

      Boy, they can’t win can they? Everyone moans for months about the lack of bookmarks, and when they deliver, it’s “but what are you doing for me now?”. 😛

  • http://eser.ozvataf.com/ Eser Ozvataf

    Sync is very essential for modern browsers as much as tab support. And still waiting for sync…

    • ahoj1234

      I hope that you will wait a bit longer… Because sync is not working as expected. (I deleted like 4 folders, 10 bookmarks and after enabling sync it was all back! deleted things were instantly restored… only the only one device was running)

      • http://eser.ozvataf.com/ Eser Ozvataf

        Lets hope they’ll fix it soon. It was more important than bookmark sharing or tab preview features.

  • sgrandin

    Print: Handsome print module except…

    – Scaling within the print module is essential; otherwise one has to to use another browser to get for get it (IE, FF); scaling allows user to save paper, get more or less of the right side on a single page when needed; and to accommodate poor page/site programming.

    – Helpful to have a way to set “more options” as default, and even to set specific options as default

    – At Scottrade.com > My Account > Gains/Loss Unrealized, the page’s Print link (far right) returns an about:blank page (“print preview failed”) and thus 0 pages. Closing or cancelling it returns another about:blank screen with the page info showing, and clicking on its Print button (top) opens print preview properly. The problem then becomes the inability to scale the page so to eliminate unnecessary info on the right side and thus allow everything else to be larger.

  • sergiol

    waiting for 26 stable to finally install (I still have 12.17 and I am currently using most of time IE because it became more power-user friendly than latest Operas)

  • Sidney Moraes

    Thanks for DNA-29883! That will be applied to Opera developer which has the same bug?

    • Marcin Mitek

      If it’s on the stable branch it means that in 99% of cases it was fixed fixed for the developer also.

      • Sidney Moraes

        So this is 1% of the cases because the problem persists in developer.

        • Marcin Mitek

          This is 0.5% case when it was fixed day after last developer release 😉 Then it was cherry picked to the stable branch, which was released yesterday. Next developer release will contain the fix. I hope now it’s clear.

          • Sidney Moraes

            It is clear, thank you 🙂

  • Jin

    Thank you for DNA-29883 fix!
    Now Opera detects ppapi flash on my Win 7 x86 😀

    • eAddict

      Share please! How do I get my v27 on Windows 9 working?

  • https://twitter.com/Yarziel Raúl Garofano

    Waiting stable version Linux. 🙂

    • P0lip

      Really? What do you need Opera for? They can’t even provide us a rpm package, because it’s too difficult (or they are just lazy or don’t care about Linux) for them. It’s not a problem for me to build the package, but for some users it may be very problematic. Notice, each browser I’ve seen, had the official (not the ones written by users) packages for most distros. Old Opera had the rpm package. Frankly, I’m very disappointed, because I had to abandon Opera – I used Opera for almost 8 years. Nowadays, Opera sucks so much. They are like “we must be cool, so let’s copy some stuff from Chrome or Firefox”. They are constantly losing their market. In Poland they used to have 10% market share. Now, it’s not higher than 5-6% – and it’s getting lower day in, day out.
      Please, give us:
      1. A proper repo for yum for auto updates to let other normal users install Opera.
      2. Bring some (it doesn’t have to be all) old features (maybe create a pool and let us vote to choose the most important?).
      3. Make Opera more customizable.
      4. PPAPI plugins should be built-in aswell (if it’s possible) just not to force us to install Chrome. It’s honestly very funny. Install Chrome, then Opera. Why on hell should I install later Opera when Chrome (with extension for speed dial) has more features than Opera? 😀
      That’s not much. Believe me, a lot of users won’t move to new Opera due to lack of some features and new, imho, worse layout. And, I don’t mean power users, but these normal ones, who are used to use the Presto based one.

      • zmwangx

        Make Opera more customizable.

        I don’t think they want to make it more customizable, as least not the way you want it, since now it’s mostly laymen-focused as far as I can tell.

        maybe create a pool and let us vote to choose the most important?

        I second this. You know what, several months ago they created a poll on how you put tabs into use, as if tabs are not obviously essential. You see how laymen-focused it is.

        … worse layout.

        I doubt that.

      • SQL

        Supporting rpm packages really isn’t a priority at this point, the same goes with 32 bit linux packages.

        Rpm will be supported in the future officially, i’d guess. Just not in the near future as they want to have the current 64 bit .deb’s as polished as possible since it has the highest marketshare of all. It’s really that simple. If all of a sudden 70% of the linux users switched to distros that use rpm then sure Opera would support it asap.

        • P0lip

          Some people use Linux, because they have an old hardware, so a 32bit version would be appreciated. Also, 30% is still a lot.

          • SQL

            The 30% was just a bet, not sure about the userbase really :p

            But really, almost all computers these days are able to handle 64 bit, and it’d be worth to install a 64 bit OS even if you don’t have much ram.

      • ghjkl

        Yep.. Currently thinking to switch to something like

        telnet http://www.google.com 80

        • P0lip

          I meant you can use either Firefox or Chromium or anything else 😉

      • http://ruario.ghost.io/ Ruarí Ødegaard
  • Mister

    Please make an option to disable auto-update )

    • koss_x_treeme

      yess i want an option for disable auto update !!

    • sergiol

      Hmmmm, They are under the Google dictatorial way of doing things. so it is questionable if they will ever disable auto-update.

    • b_sardine

      yes me too!! come on opera, comodo dragon have it. please give us that option

  • https://irrelevanteblog.wordpress.com/ Hector Macias Ayala
    • icetom

      again they put it on the server before announcing it.

      • Leonardo Gomes

        This is how things has been working since ever. And i don’t think it will change.

  • escruting

    It says Adobe flash player is out of date and i cant play youtube videos. I have the version just before the last.

    EDIT: it works if i disable the ppapi one and leave enabled the npapi version.

    • escruting


      • Will Henderson

        i have the same issue with Opera 26.0.1656.24 as you did with the new beta. it won’t let us be able to do anything, as in we want to use the outdated version of the flash NPAPI as i have a computer which can’t handle the newer flash player versions well and is the last known version to work perfect for it and it’s been outdated for about 4 to 5 years now.

        please opera fix this to were if we are using the older flash player versions we have a choice to where we can chose to use the current old flash player version if we want to. chrome and firefox let’s us be able to use the older flash player version. it wasn’t broke, you didn’t need to fix it.

    • Osiris

      I’m experiencing this the opposite way around.

      I only had the NPAPI flash installed and was recieving the “Out of Date” error on YouTube. So I installed PPAPI flash and it works fine with that installed and NPAPI disabled.

    • iseult23

      It is very annoying. I have updated the flash player but it still does not work. Pages take much longer to load, also.

  • pornocko

    How do i enable developer mode for extension in latest stable version for 32bits arch? I don’t have any buttons on the extensions page.

    • ghjkl

      Also how I can debug files with Pretty Print Javascript?

  • Lacedaemon
  • Carlos López

    MotoGP videos not working correctly in full-screen mode for a long time. Right and bottom edges are not displayed correctly, looking like stretched. Video controls do not respond well when in full-mode. I’ve filed issue DNA-30179.


  • http://vinczej.blogspot.hu vinczej

    In the Win32 recognizes Opera the plash plugin correctly again. 🙂

  • Fang

    A few questions. Are there plans to add sync notes like in the old opera and session support? Is it possible to opened incognito tab up next to the other tabs and not in a new window like in the old opera? Can you add stack tab options?

    • ayespy

      Not an Opera rep of any kind, but from prior discussions here I would say there’s no plan for sync notes, or native notes of any kind, no true session support (though groups of tabs might be made to serve a similar purpose), no plans to make private tabs but only private windows, and tab stacking might arrive some day.

  • Joana Silva

    In Opera Beta, the extension “TransOver” from Chrome Webstore(https://chrome.google.com/webstore/detail/transover/aggiiclaiamajehmlfpkjmlbadmkledi?hl=pt-br) doesn’t work anymore.

  • phiznlil

    Can you add the line “/usr/lib/pepflashplugin-installer/libpepflashplayer.so” to pepper_flash_config.json
    Everytime I upgrade I have to re-add it to get flash working on Ubuntu 12.04.

  • ammodytes

    there is some problems with images and exposed or white parts, they become yellow… http://i.imgur.com/ssAsgox.png


  • David

    When printing, it would be nice if preferences could be set or remembered. Personally, I never print headers and footers, but as this is the default I have to go to “More Options” and deselect “Print Headers and Footers” every time I print. I like the Print Preview feature, but the available options and functionality is limited.

  • Jademarisa

    Same crap. Don’t bother.

  • Jademarisa

    Have you actually done anything new? Save for the crappy and awkward “Bookmarks” I’ve noticed nothing new at all. Still ugly and not usable. I’ll stick to Firefox,

  • Maik Adamietz

    When we’ll see the new Opera browser appear on other Linux distro’s like Fedora? Kinda disappointed that only buntu/debian is supported to try out the Beta’s

    • https://myspace.com/bluezzbastardzz Hans-Jürgen Bardenhagen

      I’d like to see that as well, not for myself, as I’m on Windows, but the developer of the Last.fm Web Scrobbler extension only uses Fedora, too, and he has problems installing it with the existing workaround.

  • Klemen

    Hi! How can I change default printing preferences in Opera 26? I want to disable Headers and Footer on printing but I have to do it every single time I want to print. And I have a lot to print. Please help.

    • Klemen


      • Leonardo Gomes

        I don’t think there is a way to do it atm.

    • HF

      Any update on this? Using Opera 28.0.1750.40

  • https://myspace.com/bluezzbastardzz Hans-Jürgen Bardenhagen

    What’s up with the automatic update to 26.0.1656.24 today?

  • Jorton

    Hey, why no post for moving to Opera 26 stable?

  • Joquita for Disqus

    On Windows XP Pro (and probably on Windows 7 too), with Opera 26.0.1656.24, if you go to https://www.adobe.com/shockwave/welcome/ you will see that shockwave player doesn’t load. Or maybe Opera doesn’t open a DCR file, by default behavior.

    • Guest
  • Ry

    You need to update beta builds more often..if there’s going to be a long stretch before a beta is released then update it with a stable build in the form of a beta until the dev changes to a beta. That way we aren’t behind the stable..

  • L33t4opera

    New Opera beta 27.0.1689.29 – for the time being for Mac and Windows 😉

  • MrSwartz

    I hate the new sparse way to configure Bookmarks. I do not want another version of Windows 8 but it looks like they are trying to mimic it. I want to have my old verson back as I want to file them as I bookmark them. I do not want to have to “search” for my bookmarks, I want to open can click. Why won’t they let us configure it like we want rather than what they think I want.

  • MrSwartz

    I also hate the LESS IS MORE movement when it comes to browsers. They are all taking off all controls, options and configurations so we have no choice but to use it their way or no way. I guess I will go back to an old version of Firefox, I don’t like their new version either. I want to do it my way. I wish they would learn that. GIve us a million options and let us do it OUR WAY. Even if I want to do it like 5 yrs ago. so what, or I can opt for the nothing there but one button look. IT is my choice not yours.

  • Henry

    Adobe Flash Player is out of date and can’t look at anything with flash.

    Everything was working fine a couple of days ago … now nothing.

    Version:27.0.1689.54 – Opera is up to dateUpdate stream:StableSystem:Windows 7 32-bit

  • eAddict

    I am running v 27 and can not get Flash to work. Ugh! Driving me back to chrome or worse (IE!!)

  • Muhammad Syahid Suhayl Kadir

    i know it go to here http://labs.adobe.com/downloads/flashplayer.html good lcuk

  • Jmartin

    adobe flash player out of date. Newest flash is installed. Chrome is working fine. explorer and Opera both have outdated plugins that I cannot replace.

  • chastua

    I’m running Opera 28 on Win xp pro and flash player is unwatchable. WTF?