Opera system requirements

These requirements only apply to Opera. Third-party plug-ins such as Flash, Java, and others may have additional requirements.

Windows

Opera 23

Recommended configuration:

  • Windows 7 or later
  • 512 MB of RAM
  • 300 MB of free disk space

Mac

Opera 23

Recommended configuration:

  • OS X Snow Leopard (10.6) or later; 32-bit and 64-bit Intel systems supported
  • 512 MB of RAM
  • 300 MB of free disk space

Linux and FreeBSD

Opera Developer 24 for Linux

Recommended configuration:

  • Ubuntu 14.04 or later
  • 512 MB of RAM
  • 300 MB of free disk space

Opera 12

Opera will run on any modern Linux distribution and FreeBSD 7 or later with Xorg installed, on i386 and x86_64 CPUs.

Recent versions of the following Linux distributions are officially supported:

  • Debian
  • Fedora
  • RedHat
  • Ubuntu
  • openSUSE

Although not officially supported, we strive to make Opera work on the following distributions, and it normally does:

  • Gentoo
  • Arch
  • CentOS
  • MEPIS
  • Mandriva
  • Mint
  • Sabayon
  • Slackware

Note: Opera may run on older hardware or an older version of an operating system however it is likely that it will be less usable. You can download an earlier version of Opera that may work with your system from our download page. Just click the Show other versions link.

If you are using old hardware or an old operating system and Opera fails to start up, unfortunately Opera is not suited to your system.

Download resources