Hi, here is our weekly update on beta stream.

Highlights
  • Synchronisation: Some of you had problems with login using previous version. Now it should be fixed. Please check if everything works correct now and let us know if anything goes wrong.
  • Suggestions: There are some UI fixes included.
  • Crash on adding own theme in private window is now fixed
  • For more details, please check our changelog.

Installation links:

Back to top
  • x a

    First! Too bad I tend to only test the developers’ edition. Sorry for not being helpful. 😉

  • MilSF

    Strangely enough, I can’t get Synchronization to work at all now. I try to sign in, the process completes without error, but it never seems to actually sign in. The “Sign In” button still shows and I can’t go to Advanced Settings.

    • Kornelia

      We will investigate this.

    • Kornelia

      Will you send me your login via email? It would be really helpful. My email address: kmielczarczyk@opera.com

  • Spideymang

    Thank you for the update Kornelia and Opera team

  • Eoin Riedy

    I keep getting:
    “Sign in
    Signature invalid.”
    I’ve checked the address and the password in password manager and they both seem correct. What can I do? I can’t go to the help forums because I can’t log on. I can get here because I’m on Disqus.

    • Kornelia

      Hi, unfortunately we’re not able to reproduce this issue, so we need more details to solve your problem. Could you tell me where do you see ‘Signature invalid’? Is it synchronisation window or https://auth.opera.com/account/login? Meanwhile, if you could send me your login via email, that would be really helpful. My email address: kmielczarczyk@opera.com

    • Do you’ve this error while signing in into the sync via login popup or while signing in on forums.opera.com (as you mentioned you couldn’t reach help forums)?

  • Cobalt
  • guru b

    I can see I have passwords in my Sync profile online, but I can’t get the passwords to sync. Think sync is broken. I have signed out and signed back in too.

    • Kornelia

      Thanks for the feedback. We’ll investigate this.

    • Jakub Ryć

      Hi, @guru_b:disqus, do you have the same problem with latest Opera Developer too? Could you please check. After logging into sync, please also check Opera settings > Browser > Advanced configuration, do you have sync passwords checked? Please send me details regarding your sync problem via email. jryc@opera.com, I’ll investigate it.

  • Pau B

    Opera 39.0.2256.48 crashes if two Opera windows are opened and I close one of them, no matter if it is private or normal window, with one or more opened tabs.

    But if the Opera window is closed without having opened tabs, only the speed dial, it does not crash. Weird!

    • Kornelia

      I’m not able to reproduce this crash on Mac, Win 7, WIn 10. What is your operating system? Any features on? Adblocker for example? Any extensions added?

  • I’m having new problems with how Opera is interacting with the blogger back end, especially when I try to edit my template HTML. It continually navigates away and I get this rubbish instead with a blank page. https://…/b/app-preview?token=VRyko1YBAAA.YlYtlqXIeYFE8scW69AbpEKySZzQSZmpAyMUrcP8IDWMb9-bs8O2HC7mopoIKEcJ.oMeDAB-t9EX8228kF664ew

    I’ve been using Opera for over 2 and half years now with blogger and today this happens.

  • Cobalt

    Thx =)

  • Cobalt

    No preview of the embedded YouTube video that is played

    Steps to reproduce:
    1. Open the website/forum which has embedded YouTube videos: http://jpegshare.net/fd/e7/fde77e9d10d1e3ff260576968b563677.png.html
    2. Press the Play button on one of these videos

    Actual result: In the preview window is not displayed embedded YouTube video: http://jpegshare.net/04/8c/048c253be8556a3be2dcea562271fb71.png.html

    Expected result: There must be a preview of the embedded YouTube video. Like on YouTube: http://jpegshare.net/c9/15/c9157cb62c88eae2ec1bdfa860446c31.png.html

    Example: http://nightmarish-dream.ru/forum/index.php?showtopic=205&view=findpost&p=244407

    DNAWIZ-5724

  • Cobalt

    Strange display of some elements on the website in the preview of the tab

    Actual result: http://jpegshare.net/e6/e9/e6e90c102ee74f12a25118c57d676ed7.jpg.html

    Expected result: http://jpegshare.net/6a/ee/6aeefb9886719d2892c188d7061f2eb8.jpg.html

    Website: http://nightmarish-dream.ru/forum/

    DNAWIZ-5725

  • Chawoobie

    How do I disable the video popouts/popups? I’ve tried disabling in flags, and also in setting, but they keep coming back.

  • Cobalt
  • Nellaiseemai

    Very nice. very responsive. I am using all three channels of opera browser. Can any one tell me how to remove the space on top of tabs on Opera stable build (which is not present for opera dev and opera beta). There is a little space on top of each tab which is kind of wasting space and if I click there do nothing. Thanks.

    • DMCA

      Browser settings > User interface

      • Nellaiseemai

        Thanks for your help.

        It comes up after selecting “show advanced settings”. Is there any reason why this is only with Opera stable but not with Opera Dev and Opera Beta.

        • Leonardo Gomes

          They may have changed something.

  • Nellaiseemai

    Installed “download chrome extensions” add on – Opera Stable 41.0. Installed chrome cast add on from chrome extension. Chromecast is not at all working.

    But with Opera Developer and Opera Beta chromecast extension installed as given above working really well. It is strange considering the fact that an extension not doing well on Stable channel in comparison to opera dev and beta.

    If its a known fault ignore my ignorance and point me how to solve this if there is a way.

    Thanks in advance.
    System Win 7.

  • lb

    Netvibes.com login is still broken, no username/pw fields are visible.

    • Ralf Brinkmann

      Just tested with my Opera beta on W10x64: Everything is visible here. I think something is blocking on your system.

      • lb

        Deactivated all extensions and plugins, cleared cache, restarted. Still not working :/

        • Ralf Brinkmann

          And the funny thing is: I have uBlock origin, Ghostery and HostsMan running (activated) and it works. Maybe you can try out to close Opera, rename the profile folder (for testing purpose only) and restart Opera now with a fresh and virgin profile. Is there a difference now?

          • lb

            It does. I cleared out my actual profile folder from anything that looks it’s a cache file and it works now. Not sure which file was the culprit, might have been the one named “Local State”. Cheers!

  • ugur arslan

    teknoly sitesinde düzgün çalışıyor.

  • Junaid Ahmed

    If you turn on “Show color on title bar” in Windows settings, all apps change color of title bar(including Firefox) except Opera beta. It doesn’t change title bar color and looks ugly. This color give me headache.

    • Leonardo Gomes

      Settings > Browser > User Interface > enable ‘Show system colour on top bar’.

    • Junaid Ahmed

      Thanks! Shouldn’t it be the default behavior as Windows already has the option for people who want to see colored(classic) title bar?

  • crisiskids

    Apparently I cannot find the user or developer platforms, proper, so here I am.

    Hi – I am totally new to Opera “anything”. Is there a volunteer that could help me get my Opera browser settings correct and Opera email settings adjusted and correct – I cannot seem to figure them out, sorry. Thanks. Erik.

    • Leonardo Gomes

      Opera doesn’t have an email client.

      Regarding other settings, just ask what you want to know and someone may help you.

  • TheAnarchyReaper

    The magnet links for torrent no longer works

    • Leonardo Gomes

      Did they ever worked?

  • sgrandin

    Parts of Sports unstable with Opera 40b:
    1) Page not sizing to window (Win 10)
    2) Scroll to bottom jumps back up aways

    https://sports.yahoo.com/mlb/los-angeles-dodgers-cincinnati-reds-360822117/

  • axelet
  • Nellaiseemai

    Opera Beta 40.0.2308.15. Win 7.
    After update all my addons are gone. I had disconnect, https everywhere, ublock origin. They all missing. But browser is sill synced to my account. Thats fine.

    another issue with Opera Stable, chromecast addon not working. The pop up window upon clicking the addon symbol on the browser does not show anything. Blank.

  • Dask

    The “Add a site” button for the speeddial doesn’t work in this version of the beta

  • Chawoobie

    How do I turn off video popout? I’ve tried disabling it in websites options under settings, and tried Opera://flags without success – they still keep popping up and it is annoying.

  • mikemanger

    I don’t seem to be able to remove the amazon speeddial suggestion.

    • Kornelia

      It’s a known issue and already fixed internally. The fix will be available with the next update.

  • ive

    Sync messed up my bookmarks. AGAIN.

    Good that I have a bookmark addon that can save my bookmarks locally, because you are doing a horrible job with my bookmarks and don’t even give us the possibility to save them otherwise.

    I just saw that I wasn’t logged in for sync, no idea why that happens. Saved my bookmarks, logged in and now I got duplicates all over the place. Can’t believe this keeps happening.

    edit:
    – it seems like everything that I deleted since I got logged out is back where it was
    – everything I moved (e.g. to another folder) is now in both folders
    – renamed bookmarks are now there twice, old and new name

    edit2:
    So I could clean it up, good thing I haven’t done that much, haven’t been logged out very long and had my backup to be sure. Now is there a way I can prevent this from happening again?
    I am using Opera beta 40.0.2308.15 on Windows 7 64 bit.

    edit3:
    Just checked online: https://sync.opera.com/web/#
    Seems like it’s mostly like it is on my computer. Except for speeddial and one folder that’s pretty messed up.
    I am also using and syncing Opera mini on Android. My Computer’s speed dial and the mentioned folder are normal on my phone and computer. Only online it’s different. How do I fix this so I don’t get all those bookmarks i see online some time in the future? Specifically: How can I delete a bookmark that’s online but doesn’t show on my computer? If i bookmark it exacty like it is online, I just get it once more, I delete it on my computer -> the new one is gone online.

    edit4:
    For the folder I could get it right:
    – renamed it, copied&pasted the folder, deleted the “original”, renamed the copy.
    Now for the speeddial? No idea how i get rid of it and I am sure this will haunt me some time in the future when sync is messing up again.

  • sgrandin

    Beta is returning a garbled text page at Costco Citi Visa card, https://online.citi.com/US/JPS/portal/Index.do, and logging on doesn’t work there either, just returns the same page. Not sure when the last time I tried was, but am sure it wasn’t the case with betas earlier this month and in July. Works fine with Opera 12.xx and other chromium-based alt-browsers.

  • sgrandin

    It’s truly bizarre: In Speed Dial, I click on ‘+’ to add a site I currently have open (tab) and Opera offers me lots of “Suggestions” – Nordstrom’s, Wal-Mart, Priceline, WebClipper, etc., etc. – but does not offer any of the tabs I have open! The new one has to be entered manually. I don’t think it’s unfair to see this as a measure of how far Opera’s come down from its origins, certainly from the origins and purpose of the Speed Dial.

  • Pietro

    This beta is impressive. I´m working with WordPress and testing all the addons. Everything working fine at high speed and stability!

  • Vux777