It’s a fast-paced beginning of the year: today, we have the beta update, first one in 2016. This is a maintenance update with the following highlights:

  •  We have improved stability and performance in both the regular and Turbo modes.
  •  We backported the DNA-47276 renderer crash fix.
  •  The bookmark deduplication should now perform more smoothly with the fix of DNA-47472.
  •  Linux users should now be able to enjoy Netflix videos – please check out!

Chromium has been updated to 48.0.2564.71.

For the full list of fixes, I’m inviting you to check out the changelog – a short one, but full of merit.

Installation links:

Changelog: Full changelog link

About Aneta Reluga

Working at Opera since November 2010. Keen photographer, avid Pentaxian, occasional oriental dancer and wannabe dramaculous native language wordsmith; currently in the Desktop QA Team.

Back to top
  • nanana1

    Thanks, Aneta, for this first 2016 Opera 35.0.2066.23 Beta update which provides significant stabilization fixes !

  • Łukasz Jagielski

    Small comment about the Netflix support on Linux, it’s not so straightforward to make it work. This is what you need:
    – compatible widevine libraries (see /usr/lib/x86_64-linux-gnu/opera-beta/resources/widevine_config.json for search paths, version 48.x). I’m pretty sure some distros have a separate package for it with some custom installation dir, please let me know about that in comment 🙂
    – ffmpeg with h264 support (e.g. chromium-codecs-ffmpeg-extra version 48.x)
    – fake user agent to Chromium (–user-agent command line switch)
    This version 48 is determined by chromium version our product is based on, major version mismatches sometimes work, but no guarantee.

    • Ricardo J. Barberis

      I’m probably missing something :/

      I’m on Slackware 14.1 64 bits, using chromium+chromium-widevine Netflix works OK.

      With Opera beta impersonating Chrome (*) and the correct paths in widevine_config.json, netflix starts loading but errors out with “Error code: M7355-1203”.

      Disabling plugins (flash, pdf viewer) doesn’t help.

      Any advice?

      (*) Identified as:
      User-Agent:Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.82 Safari/537.36
      Browser:Chrome 48.0.2564.82
      Engine:WebKit 537.36
      OS:Linux x86_64

      • Łukasz Jagielski

        Hi, you need one more thing which is ffmpeg with h264. I see that it’s distributed with chromium package in slackware, so you should edit your /usr/lib/x86_64-linux-gnu/opera-beta/resources/ffmpeg_preload_config.json and add path /usr/lib/chromium/lib/ there

        • Ricardo J. Barberis

          I’ll have to try on slackware current (or wait till 14.2) as the libraries from chromium-dev-49 require a newer glibc than 14.1 has, and with the libraries from chromium-47 I still get the same error.

          Thanks for the help!

    • Ricardo J. Barberis

      Ah, I have chromium+chromium-widevine 47.x, I’ll try upgrading to 48…

    • Ricardo J. Barberis

      I couldn’t get 48.x but tried 49.x, same error 🙁

      User-Agent:Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2593.0 Safari/537.36
      Browser:Chrome 49.0.2593.0
      Engine:WebKit 537.36

  • deus-ex

    When downloading files with the file extension .exe, Opera creates a subfolder named “exe” and stores the downloaded file into that subfolder. So far I witnessed this behaviour with .exe files only. This bug appears to be introduced with the previous release Opera developer 36.0.2079.0.

  • ZeeWolf

    I’m having weird bug. When opening private window, then application is not accepting any keyboard input. Can’t enter anything in address bar, can’t enter anything to input fields on web pages… It happens every time. Anyone had similar bug ?

    • Tommy Wille

      Which OS are you on?

      • ZeeWolf

        Win 7 x64

    • EchoFromSpace

      I’m having the same bug. It started in the first 35 beta, I think (never used developer). If I leave the private window open, after a few minutes, typing suddenly works.
      This is on my home computer which has Windows 7 x64. On my computer at work which runs Windows 8.1 x64, this doesn’t happen.

      • ZeeWolf

        You’re right, after leaving browser for few minutes it suddenly works heheh. @tommywille:disqus any thoughts ?

    • Matthias Lech

      Same annoying problem here under Win7 x64.
      But it happens only when you open private mode from a maximized window.
      Opened from non-maximized windows private mode accepts input properly.

  • Robert

    1)Opera is set to ssd but includes a very long time, while the chrome edge and run instantly.
    2)All also hangs when you turn the movie and switch to HD.
    3)All also hangs on the website
    4)Blink when switching between Speed Dial, tabs, news, bookmarks, history.
    5)Not smooth loading pages in YouTube.

  • Pavel

    Hello, When are you planing to release v35?
    I am really tried of duplicated bookmarks…. :/

    • Kari Ikonen

      ME TOO! (emphasis intentionally applied).

  • Sławomir Szewczyk

    Linux Chakra x64 Fermi: Netflix not supported:

    On Google Chrome and Vivaldi service Netflix is working properly.

  • Dark Magician

    Sync has to be encrypted so you don’t have access to it. Like it’s done on Firefox.
    I will never use it this way.

    • Tommy Wille

      What should be encrypted in your opinion, everything? As of now, passwords are encrypted at least. And you cannot have access to them until you type your master password or account password.

      • Dark Magician

        Everything. I know passwords are, so I don’t why that isn’t extended to the rest.

  • Kev87

    3 builds in one week! What a start of 2016 🙂

  • Artiom

    When will the release of Opera 35?

    • Leonardo Gomes

      This year. 😀

    • Kev87

      I one of the following weeks. Depends of the work the devs still need to do.

  • Joana Silva

    Every time there is an update I have to create firewall(not Windows built-in firewall)rules of exception manually. This is kind of counterproductive, since only with Opera happen this problem. When this issue will be solved? Anywhay, thanks for the great browser. 🙂

    • Leonardo Gomes

      Have you tried give acces to launcher.exe instead of opera.exe?

  • Robert

    1)Opera is installed on the SSD,opens for a long time.
    2)All also hangs when switch the movie to HD.
    3)All also hangs on website
    4)Flickers when switching between Speed Dial, tabs, news, bookmarks, history.
    5)Not smooth loads pages in YouTube.
    6)On site all of the content disappears after a couple of seconds, displayed blank page.
    7)Sometimes it does not load comments.

    • [828586]

      don’t bother, they will never fix this issues, I found fix for long open problem just disable cache and autoupdate I don’t know which helps but is better (auto update is useless since they never solving real problems) ” -noautoupdate –disk-cache-size=1 –media-cache-size=1″

      I have another problem which I would like add to your list, long closing even one minute have to wait between press X button and window disappearing

      • BK

        Hi, what is your OS?

        • [828586]

          Windows 7 x64

          • Aneta Reluga

            Ok, thanks. How many tabs do you have, and what are your OS specs (RAM, processor, GPU)?

          • [828586]

            i7 3,6 GHz, 16GB, Nvidia GTX970, even with one tab can behaves like I described, for example this page

          • jho

            have you tried to disable hardware acc.?

          • [828586]

            still the same

    • BK

      Hi Robert, can you try to install clean opera as USB installation, just for performance test, and let us know?

      • Robert

        Also no, change

  • vikas kumar (Викас)

    Great , Had issues rendering there on earlier version, now works as smooth as crome.

  • maartinez

    Could someone please help me? Since about three latest releases when I try to watch mp4 videos opera is trying to download them instead of just playing. YouTube videos are working fine. Where should I search for the problem? I’m on Ubuntu 15.04, Opera beta 35

  • Druszlak

    I’m facing strange bug since last beta build : when I open new private window I cannot input any signs by keyboard for few seconds/minutes (neither in address bar nor speed dial). Is this spread widely or just me?

    Windows 7 64-bit

    • Vux777

      yea, same here…fresh usb install, no extensions at all

  • TomR1986

    Please, Please start brining back customisable UI, like you had upto Opera 12!!

  • Harry

    Sorry if this is in the wrong forum, but I have to ask this question.

    Is there any chance of bringing back the old Fit to Width option as in version 12? This was one of the features of Opera that made it amazing.

    The existing addons for FTW, (Opera and Chrome), are completely useless.

    If there is a chance, please make it a priority. If not, could you let us know once and for all.

    Thank you.

  • L33t4opera

    New update – Opera beta 35.0.2066.35 😉

  • RichInBCS

    I wish it were possible to maintain the number of columns on speeddial screen stable. When I switch from my large screen to the laptop screen, the number changes, meaning that the placement of the icons changes depending upon which screen I’m using.